Intel Wireless Card (iwi)

The intel wireless nic (102.11b/g) that is built into the Toshiba M30 laptop is only recently supported in FreeBSD (as of FreeBSD 6.0 beta1). This driver is evolving and this how-to may need some updating by the time you try and use it.  Please check the driver for the latest information.  Information on the driver can be found at http://damien.bergamini.free.fr/ipw/

NOTE: This driver is now included in FreeBSD (versions > 6.2R) and some of the procedures listed here are no longer needed. Check out:  man iwi

Load the module

Add the following modules to /boot/loader.conf
# echo if_iwi_load=\"YES\" >> /boot/loader.conf

Kernel Changes

The following lines need to be added to the kernel file and a new kernel compiled.
     device      wlan
     device      wlan_wep
     device      wlan_tkip
     device      wlan_ccmp
     device      wlan_acl

Install the driver firmware from the port

# cd /usr/ports/net/iwi-firmware
# make
# make install
# make clean

Remove the startup script it installs
# rm -f /usr/local/etc/rc.d/iwi.sh

Allow devd to detect and install the firmware.

Create the following file in /usr/local/etc/devd/iwi.conf

# devd configuration file for the iwi device.
# this will download the firmware to the card on the attach.
attach 100 {
    device-name "iwi0";
    action "/usr/local/sbin/iwicontrol -i iwi0 -d /usr/local/libdata/if_iwi -m loss";
};
# start the dhclient on link up if configured for DHCP
notify 100 {
    match    "system"       "IFNET";
    match    "subsystem"    "iwi0";
    match    "type"         "LINK_UP";
    action   /etc/rc.d/dhclient start iwi0;
}

Configure the iwi device to startup.

# echo ifconfig_iwi0=\"DHCP\" >> /etc/rc.conf